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1. INTRODUCTION 

TEMimage is the TEMcompany’s processing software developed specifically to make TEM data 

processing as simple and accessible as possible. It supports data from multiple TEM systems, 

including sTEM, sTEM Profiler, tTEM and TEM2Go, and the equivalent instruments sold by Guide-

line Geo (GroundTEM i-series, Ralli and Trek) 

The software uses TEMcompany’s own inversion code (Lupus) and is designed for both beginners 

and advanced users. Beginners can rely on default inversion settings for quick results, while ad-

vanced users have access to a wide range of detailed processing and inversion options. 

In addition to viewing electromagnetic data in raw dB/dt, stacked dB/dt, and apparent resistivity, 

TEMimage allows users to process and visualize inverted data in various formats, including 1D 

models, resistivity sections, and resistivity depth slices. 

The resulting models can be exported in multiple formats, making it easy to integrate results with 

other software and GIS platforms. 

This document explains how to import, process, and invert time-domain data collected using our 

instruments. TEMimage is optimized for data collected in a line and is particularly well-suited for 

generating profile sections. 

Before You Begin 

Please review the following requirements before proceeding: 

• TEMimage is compatible only with data collected using TEMcompany products. Other 

data formats are not supported. 

• It requires datasets recorded in dual-moment mode; both Low Moment (LM) and High 

Moment (HM) data must be included. 

• For best performance, use the original project or data folder structure as downloaded 

directly from the instrument. 

• A valid product key is required to activate the license and run the program. 

• If you do not have a valid product key, please contact: support@temcompany.com. 
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2. GETTING STARTED 

2.1 Activating the license 

Once the program has been installed and launched, you will be prompted to activate your license. 

To do so, follow these steps (Figure 1): 

• Enter the provided Product Key in the designated field. 

• Click on “Checkout license” 

• If activation is successful, the top bar will turn green and display “License is active.” 

• Once activated, additional license information will appear in the field below, including: 

o Expiration date  

o Support expiration date  

o License ID  

o Active users  

o Offline checkout remaining  

o Allowed instrument types 

• To deactivate the license, Open License Manager and click on the “Check-In” button 

 

Figure 1: License manager window. “License not Active” (left) and “License Active” (right) 

Notes: 

• The licenses are usually perpetual, meaning the expiration date may appear unusually 

far in the future. 

• Software support and updates are renewed annually. The support expiration date indi-

cates when this period ends. 

• Maximum activations refers to the number of users who can access the software simul-

taneously using the same product key. 

• Active users show who is currently using the software. 
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• Offline checkout remaining indicates how long the license can remain checked out. 

When working offline, this also defines how long the software can be used without re-

connecting. Once expired, the license must be checked out again while online. 

2.2 Startup screen 

 

Once TEMimage is installed and a valid license is checked out, the startup screen will appear as 

shown in Figure 2  

 

Figure 2: Startup screen displayed after launching TEMimage 

Menu Bar Overview 

The menu bar located in the upper left corner, provides access to the following options: 

• File – Import, export, save, and access settings. 

• Visualization – Options for manually creating profiles and resistivity layer maps based on 

inversions (see Section 6). 

• Options – Includes advanced processing selections and the option to update DEM (ele-

vation data). 

• Help – Displays application version details and license manager. 

2.3 Adding a new map provider 

In TEMimage, background maps can only be added using WMS (Web Map Service) layers. By 

default, the application loads the Open Street Map. However, you can add other WMS layers as 

long as you have a valid URL and access to it. 
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Adding a new online background map (Figure 3): 

• Right-click on the map window. 

• Select "Add new map provider". 

• Enter a name for your map (e.g., “MyMap”). 
• Paste the valid WMS URL. 

• If the URL is valid, the new background layer will be added automatically. 

 

Viewing and setting the new background layer: 

• Right-click again and select "Select Map Provider". 

• You should see the newly added background layer listed. 

• Select it to set it as an active background map. 

 

Once selected, the new map layer will be saved with your project and remain active until you 

choose a different one.  

 

Figure 3: Adding new map provider and managing map providers 
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3. DATA IMPORT  

To begin, click on File and select Create New Project. A window will open prompting you to cre-

ate a database file (.db), where all processed data will be stored.  

Once the database file is created, an Import Data window will appear (Figure 4). Here, you must: 

• Select the data type (sTEM/sTEM Profiler, TEM2Go or tTEM or GroundTEM equivalents). 

• Choose the Data folder containing the acquired measurements. 

Importing sTEM or sTEM Profiler Data 

When importing sTEM or sTEMprofiler data, TEMimage automatically performs the following: 

• Reads all .stb and .stn files from the selected Data folder(s) 

• Processes and stacks the raw data into soundings, including associated GPS positions. 

TEMimage does not support datasets without GPS information. 

• Groups data by line number. If line number information is missing or duplicated, there is 

an option to assign a new line number automatically. 

• Multiple datasets of the same data type can be imported into a single project in TEMi-

mage. In addition, sTEM datasets from different configurations (eg. 40x40 and sTEM Pro-

filer) can also be combined and processed within the same project. 

 

Figure 4: Import data window  
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Importing TEM2Go or tTEM Data 

When importing TEM2Go or tTEM data, additional options are available: 

• Select Production Line File (.lin) 

o If a .lin file is selected, it defines how the data is split into lines. 

o If no .lin file is provided, TEMimage will automatically split the data, but will keep 

all data including sections where the line was otherwise “stopped”. 

• Processing Options – Station Interval (m) 

o Defines the spacing used to average raw measurements into stations 

 

Data Display After Import 

After import, both Low Moment (LM) and High Moment (HM) data displayed, along with a map 

showing the location of the acquired measurements (Figure 5).  

• All GPS positions are shown as black points 

• The currently selected line is highlighted in red 

• Map display settings can be adjusted by right-clicking on the map and selecting Map 

Settings 

 

Figure 5: Overview of the home screen after importing (in this case) TEM2Go data. 
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4. DATA PROCESSING  

When data is imported, TEMimage automatically applies a slope filter to the averaged data. This 

filter will auto disable the oscillatory data points due to couplings from external sources. 

After import, the data must be manually reviewed and adjusted by enabling or disabling specific 

data points in the Low Moment (LM) and High Moment (HM) profile plots (Figure 6). This ensures 

that only high-quality data is used for inversion. 

In projects containing multiple survey lines, you can switch between them using the Line Naviga-

tion option in the panel on the left(Figure 6). 

You can manage data points in two main ways: 

1. Using the Data Profiles 

• Left-click and drag the mouse to select the data points you want to modify on the profile 

plot. The selected points will be highlighted (Figure 6). 

• From the top menu, choose Enable (or Ctrl+E) to include the points in the inversion pro-

cess, or Disable (or Ctrl+D) to exclude them. 

2. Using the Sounding Plot 

• When a data point is selected in the profile, the corresponding sounding is displayed in 

the Sounding Plot (Figure 6). 

• Click on the Sounding Plot tab to view the details. Data can be displayed in either dB/dt 

(LM and HM) mode or Apparent Resistivity mode. 

• Use the “Show Disabled” option to display data points that have been excluded. 

• Data points can also be selected directly in the sounding plot and enabled or disabled in 

the same way as in the profile view.  

Notes: 

• Pay close attention to data points near roads, houses, or other infrastructure, as they are 

more likely to be affected by noise. 

• Disabled data points are excluded from inversion but not deleted, allowing them to be 

re-enabled if needed.  
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Figure 6: Representation of TEM2Go data acquired along a survey line. Data points are selected from the 

profile plots on the left, while the corresponding soundings are displayed on the right in the Sounding 

tab (shown here in dB/dt). Line 26 (top) illustrates an example of good-quality data, whereas Line 27 

(bottom) shows data affected by noise, which should be disabled before running the inversion. 

4.1 Viewing Raw Data 

Viewing raw data can provide valuable insight into data quality and support better processing 

decisions. The method for accessing raw data depends on the data type. 

4.1.1 Continuous Data (TEM2Go or tTEM) 

For continuous data types such as TEM2Go or tTEM, raw data can be accessed directly from the 

profile view: 

• Right-click on the profile plot  

• Select Data > Raw  
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This will display the full raw dataset acquired along the selected line (Figure 7). 

Figure 7: Visualization of raw data for continuous measurements (TEM2Go and tTEM). Right click on top 

of the data plot and choose Data > Raw.  

4.1.2 Stationary Data (sTEM) 

For sTEM data, measurements are collected at fixed locations. The sounding shown in the profile 

plot represents an average of continuous stationary soundings acquired at that location for a 

selected period of time. 

To view and process individual soundings: 

• Go to the Menu and select File > Process Individual Sounding  

• A new window will open displaying all individual soundings (and corresponding resistivity 

models, if inversion has already been performed) (Figure 8)  

• Data points can be enabled or disabled directly within this window  

To view raw data for a specific station: 

• Select the desired line and station ID from the left panel  

• Right-click and select Show Raw Data (Figure 9) 
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Figure 8: Processing individual soundings for sTEM data 

 

Figure 9: Visualization of raw sTEM data 
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4.2 Creating a Custom Line 

This feature allows you to create custom lines from existing data points, making it easier to reor-

ganize data and analyze profiles in any desired direction. 

To create a new line: 

• Right-click on the Map and select Create New Line (Figure 10)  

• A prompt will appear asking you to define a search radius (in meters)  

o The search radius determines how many nearby data points are included in the 

new line, choose the radius based on the desired line direction and data density  

To draw the line: 

• Left-click on the map to add points along the desired path  

• Double-click to finish the line  

The custom line can be drawn in any direction to include the desired data points (Figure 10). 

Once created, the new line will be added as the last line in the project. It can then be selected 

via the Line Navigation panel and processed in the same way as other lines. 

 

Figure 10: Creating a custom data line. Right-click on Map > Create new line (top). Draw the desired line 

in any shape and direction and it will be created as the last line in the project (bottom). 
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4.3 Additional options  

Another advanced option in TEMimage is the ability to update the elevation data of your meas-

urements by applying a Digital Elevation Model (DEM) to the project. 

To update elevation data: 

• Go to Options > Update DEM  

• A window with different options will appear (Figure 11): 

• Use an online DEM source  

• Upload an external DEM file  

o The file must be in GeoTIFF format, and only WGS84 UTM coordinate sys-

tems are supported  

• Remove or revert a previously applied DEM from the project 

Additional advanced processing options are available under: Options > Advanced Processing 

The main tools include: 

• Sync HM > LM  

• Delete Gates and Enable Gates  

• Flip Sign 

These tools provide more detailed control over the data and should be used with care, as they 

can significantly influence the processing and inversion results. 

 

Figure 11: Update DEM window options 
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Figure 12: Advanced processing options window 
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5. DATA INVERSION  

Data inversion in TEMimage can be performed using either the Lateral Constraint Inversion (LCI) 

or the Spatial Constraint Inversion (SCI) scheme. 

Once data processing is complete, click the Invert Data button in the top panel. This will open 

the Inversion Setup window (Figure 13), where you can: 

• Select one or multiple survey lines to invert  

• Adjust key inversion settings, such as:  

o Constraint mode (LCI or SCI)  

o Moment selection (LM, HM, or both)  

• Access additional advanced settings through the drop-down menu, including:  

o Startup model setup  

o Constraint setup  

o Constraint strength  

These advanced parameters are preconfigured with default values. While they can be modified 

for more advanced inversion workflows, beginner users are advised to use with caution. 

Inversion Progress 

Once the inversion starts, a progress window will appear (Figure 13) displaying: 

• Current and previous iteration times  

• A graph showing data misfit per iteration  

The inversion process will automatically stop once the defined stop criteria are met. 

Inversion Results 

When the inversion is complete: 

• Close the progress window  

• The resulting resistivity models will be displayed in the bottom panel (Figure 14). 
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Figure 13: Inversion settings and starting the inversion 
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6. INVERSION RESULTS 

6.1 Resistivity sections 

The resistivity section created as a result of the inversion (Figure 14) can be displayed in three 

different ways (Figure 15): 

• 1D model bars 

• Interpolated  

• Both (1D color bars overlaid on an interpolated section) 

If your project contains multiple soundings or survey lines, you can switch between resistivity 

sections using the Line Navigation option. 

 

 

Figure 14: Home screen after the inversion of the data is complete. The bottom panel shows the Resistiv-

ity section for the corresponding line. If you click on a model in the Resistivity section, the Sounding plot 

on the right will show how well the forward model fits the observed data. 

Other useful information that can be obtained from the resistivity section, includes: 

• Depth of Investigation - model layers below the estimated depth of investigation are 

faded (Figure 14). 

• Data Misfit Line - a data misfit line is plotted on the y-axis of each section model (Figure 

14). 
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o A consistently high misfit value suggests the presence of poor-quality data that 

should be reviewed and possibly disabled. 

o To check the misfit for a specific sounding, left-click on the model. The Sounding 

plot will display how well the forward model fits the observed data (Figure 14). 

If inversion results are unsatisfactory, you can further process the data, disable problematic 

points, and re-run the inversion. 

Managing Multiple Inversion Models 

Each time you run an inversion, a new inversion model section is created for the selected line. 

When the inversion is complete, TEMimage automatically switches to the latest model. 

To review earlier results, use the Inversion Management panel (located below Line Navigation 

on the left) to select and view previous inversion versions. 

 

Figure 15: Display Options panel (left). Selecting different options changes what is shown in the bottom 

panel of the Home screen. The top illustration represents the Auxiliary Plot, which provides information 

about LM/HM current, input/output voltage, GPS speed, and Tx–Rx distance during data acquisition. The 

other illustrations show the three available display modes for the model plot: 1D Soundings, Interpolated 

Section, and Both (combined view). 

6.2 Model Plot Options 

The model plot can be customized in several ways. By right-clicking on a model in the plot, addi-

tional viewing options become available (Figure 16), including: 

• Model Plot Settings  

• Reset Axis Settings  

• DOI Mask  
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• DOI Opacity  

• Toggle Fit  

Additional features available from the right-click menu include: 

• Show Online DEM (if applied)  

• Show 1D Model – displays the 1D resistivity model graph for the selected model(s) (Fig-

ure 17)  

• Show Inversion Settings  

• Save Plot  

Finally, by right-clicking on the color scale, you can: 

• Select from different color scale options  

• Define minimum and maximum resistivity values for the display 

 

 

Figure 16: Right-click options for the Model plot 

 

Figure 17: 1D resistivity model graphs. To open this view, right-click on the desired model and select 

“Show 1D Model” (left). Additional models can be added by clicking on them in the model plot and they 

will be automatically included in the graph (right). 
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6.3 Creating custom profiles 

When the processing and inversion results are satisfactory, further visualization options become 

available, including drawing and generating custom profiles directly within the survey area. 

To create a profile (Figure 18): 

• Open the Visualization menu. A new window with a map of the inverted data will appear. 

• Click the Draw Profile button in the top panel. 

• On the map, click to set your profile’s starting point, then click again to set the next point 

and double click to end the profile or click Finish and Save in the top panel. 

• Enter a profile name and specify a search radius in the pop-up window, then click OK. 

• The profile will appear in the Profile List on the left panel of the Visualization window. 

• To open your profile, double-click it. A Profile Plot window will appear, where you can 

adjust display settings. 

 

 

Figure 18: Visualization window and how to create custom profiles. 

6.4 Generating Resistivity Maps 

When working with dense survey areas, another useful tool is to generate Resistivity Maps to 

visualize depth slices across the project area. These maps are created by interpolating the 
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resistivity values of a particular layer at regular grid intervals defined by the inversion layer 

model. There are two interpolation methods available: IDW (Inverse Distance Weighting) and 

Kriging (Figure 19). 

To generate a resistivity map (Figure 19): 

• In the left panel, under Resistivity Map, select the interpolation method and define the 

interpolation parameters. If unsure, use the default options. 

• Click Generate Map to create a layer view of resistivity slices at different depths. Each 

slice represents the vertically centered depth between the top and bottom of the corre-

sponding layer. 

• Use the Layer Display panel to adjust settings, such as layer opacity and slice depth. 

 

 

Figure 19: Visualization window and how to generate resistivity maps. Two interpolation methods are 

available: IDW (Inverse Distance Weighting) and Kriging (top). After clicking on “Generate Map”, resistiv-

ity layers are created and can be explored using the Layer Display menu (bottom). 
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7. EXPORT/SAVE OPTIONS 

Depending on the type of data that is exported, there are different options. 

To export data: 

• Go to the File > Export > Data. 

• In the pop-up window, select the data source: Station stacked or Raw Data. 

• The data can be exported in XYZ format only.  

To export a model: 

• Go to the File > Export > Model. 

• In the pop-up window, select the desired inversion version. 

• Choose the export format. Supported formats include XYZ, KMZ, VTK, DAT, Leapfrog 

(.csv), CSV (general) and PDF report.  

To export GPS positions: 

• Go to the File > Export > GPS Positions. 

• In the pop-up window, select the data source: Station stacked or Raw Data. 

• Data is exported as an ESRI shapefile (.shp). 

To save model plot: 

• Click the Save Plot button in the left panel, or right-click on the plot and select Save plot. 

• Choose export resolution (DPI) and export format (TIFF, PNG, SVG) 

To save profile plot: 

• Open the Visualization Menu. 

• Select the desired profile from the Profile list to open it. 

• Click the Save Plot button in the left panel, or right-click on the plot and select Save plot. 

• Choose export resolution (DPI) and export format (TIFF, PNG, SVG) 
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8. TROUBLESHOOTING 

This section outlines common issues that may occur when working in TEMimage, along with rec-

ommended solutions. 

8.1 License Issues 

Cannot Activate License 

If you are unable to activate your license, check the following: 

• Expiration Date  

o If the license has expired, please contact support@temcompany.com  

• Offline Checkout Remaining  

o If this value is 0, the license must be checked out again while connected to the 

internet  

• Active Users / Maximum Activations  

o If the maximum number of users has been reached, another user must check in 

the license before a new user can activate it  

o If it is not possible check in a license due to a computer or user not being acces-

sible you can contact support@temcompany.com to request a remote check in.  

8.2 Import Issues 

8.2.1 Import Error – Missing Data Files 

• This issue most commonly occurs with TEM2Go data due to incomplete or incorrect data 

download from the instrument  

• Follow the error message prompts to identify missing files  

• Re-download the dataset from the unit and try again  

8.2.2 Missing Data Lines (tTEM / TEM2Go) 

• If some data lines appear to be missing after import using a .lin file:  

o Re-import the dataset without the .lin file  

o TEMimage will then automatically segment all available data into lines  

• If the automatically generated lines do not match the desired layout:  

o Create custom data lines (see Section 4.2)  

8.2.3 sTEM Data Not Divided as Expected 

• If sTEM data is not grouped into the desired lines:  

o Use the Create Custom Line feature (see Section 4.2)  
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8.3 Data Issues 

8.3.1 Sign Change in Data 

A sign change is a common feature in TEM data and is not necessarily an error. 

Typical case: 

• In areas with a very conductive near-surface layer, the signal may start negative and 

transition to positive (Figure 20)  

• If this matches the geological setting, it is likely a natural effect  

• After inversion, the data should still fit the model well  

 

Figure 20: Example of a sign change in TEM data due to the presence of a very conductive near-surface 

layer (in this case saltwater) 

8.3.2 Other Causes of Sign Changes 

• Induced Polarization (IP) Effects  

o Chargeable materials in the ground can temporarily store energy and release it, 

affecting the signal and causing sign changes  

• 3D Effects  

o Caused by the geometry of the transmitter and receiver loops, as well as ramp 

time  

o More common in instruments using offset measurements  

• Coupling Effects  

o Interaction with nearby conductive objects (e.g., fences, cables, infrastructure, 

buried objects)  
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8.4 Inversion Issues 

8.4.1. High Misfit 

• If the data misfit is high:  

o Inspect misfit values for individual models  

o Revisit and reprocess data points where the misfit is elevated  

o Disable noisy or poor-quality data points  

8.4.2. Unexpected Anomalies 

• If an anomaly:  

o Does not match neighbouring data  

o Does not align with expected geology  

It may be an inversion artefact. Treat such results with caution and verify by reviewing the raw 

data and processing steps. 

8.5 General Recommendation 

When in doubt: 

• Re-check data quality  

• Compare with neighbouring soundings  

• Review acquisition conditions  

• Contact support@temcompany.com  

 

 


